Time For an Upgrade

June 30, 2009 at 2:45pm By: Mr. Wilson Posted in The Lincolnite Blog

Firefox users rejoice: Firefox 3.5 is now available.

Don’t use Firefox? Then please be sure you’re using the latest version of Safari, Chrome, or Opera. Your friendly neighborhood web developer thanks you.

What’s that? You use Internet Explorer? Ugh. OK, if you have to use IE, for Pete’s sake PLEASE be sure you are using the latest version (IE8). Every time you use IE6 God kicks a puppy. You don’t hate puppies, do you?

Reply to this post

The Comments

Fletch June 30, 2009 at 7:43pm

You can have my IE6 when you pry it out of my cold dead hands. LOL

Mr. Wilson June 30, 2009 at 7:47pm

That can be arranged wink

Fletch June 30, 2009 at 7:49pm

I just upgraded to FireFox 3.5 as well. I tend to use both.

JT July 2, 2009 at 8:31pm

IE6 is the only “fast” IE.  7 and 8 are slow boats.  like driving a bus loaded with lead weights instead of school children. 

Firefox is better for general use, but for those of us stuck in IE world (usually due to apps), 6.0 is it the way to go still.

Commenting is not available in this channel entry.

The Blogs

Syndication icon

Toolbox